
January 2022

Brilliant 
content 
that 
works

quark.com

Adapter for Microsoft Office User Guide

http://www.quark.com


Contents 

Get Started  1 

About Quark Publishing Platform NextGen  1 

System requirements  3 

Install Quark Publishing Platform NextGen Adapter for Microsoft Office  5 

Standard Installation  5 

System Setup and Preferences  6 

Log On to a Repository  6 

Preferences  9 

Set Preferences  9 

Work with a Platform Repository  15 

Create a New Document from a Template  15 

Create a New Document from a Document  18 

Open a Document from the Repository to Edit and View  20 

Save Document Revisions  22 

Discard Changes  28 

Close Server Documents  29 

Quark Publishing Platform NextGen User Interface  30 

Quark Publishing Platform NextGen Adapter for Microsoft Office - Excel  30 

Componentization in Microsoft Excel  30 

Export Ranges from Microsoft Excel  31 

Export Charts from Microsoft Excel  34 

Push Updates  35 

Smart Content Pane in Microsoft Excel  35 

Quark Publishing Platform NextGen Adapter for Microsoft Office - PowerPoint 37 



PowerPoint Slide assembly  38 

Insert Slides  38 

Component References  41 

Picture from Server  41 

Chart from server  42 

Paste from Server  47 

Video from Server  47 

Audio from server  48 

The Smart Content Pane in Microsoft PowerPoint  49 

Multi-channel Publishing  52 

Quark Publishing Platform NextGen Adapter for Microsoft Office - Word  54 

Contacting Quark  55 

Outside the Americas  55



Get Started 

This guide describes the functionality that Quark Publishing Platform NextGen® 
adapters add to Microsoft® Word, Excel, and PowerPoint. 

  

Using these adapters, you can: 

store all Word, Excel, and PowerPoint documents on Quark Publishing ●

Platform NextGen using version control. 

use a Quark Publishing Platform NextGen workflow to assign status and ●

route Microsoft Word, Excel, and PowerPoint digital assets. 

create new Word, Excel, and PowerPoint files from existing files or templates ●

checked-in to the Quark Publishing Platform NextGen server. 

create components from existing local Excel files and check in the ●

components to the server. 

insert components from the Quark Publishing Platform NextGen server in ●

PowerPoint slides. 

 
About Quark Publishing Platform NextGen 
Quark Publishing Platform NextGen is a highly configurable solution for 
complete, automated, end-to-end multichannel publishing. Quark Publishing 
Platform NextGen is purpose-built to support end-to-end publishing needs, 
from complete manual publishing systems to highly automated workflows. 

Platform consists of a set of core modules that can be combined in various 
ways and integrated with third-party systems to accommodate almost any 
workflow. Its capabilities can be described in terms of content creation, 
management, publishing, and delivery. 

Create 

Quark Publishing Platform NextGen lets you: 

design professional templates for different publications. ●

author structured content in the familiar Microsoft Word environment. ●

integrate content from databases with other forms of content. ●

utilize multimedia content such as video, audio, images, and slideshows. ●
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Manage 

Quark Publishing Platform NextGen provides: 

workflow and collaboration tools. ●

task and update notifications. ●

component management. ●

automated checks. ●

version control. ●

 
Publish 

With Quark Publishing Platform NextGen, you can: 

automatically assemble components of various types from various sources ●

into sophisticated layouts. 

automatically publish layouts in a variety of formats for a variety of devices. ●

 
Deliver  

The automation features built into Quark Publishing Platform NextGen make it 
easy for you to deliver content to your content consumers in both public and 
secure environments.
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System requirements 

Quark Publishing Platform NextGen Adapter for Microsoft Office require the 
following minimum hardware configuration: 

Processor: Intel Core i5, 2.5 Ghz (Intel Core i7, 3.4 Ghz recommended) ●

8 GB of RAM (16 GB recommended)  ●

10 GB of available hard disk space  ●

Display with 1024 x 768 or higher resolution monitor  ●

Peripherals suitable for Microsoft® Office authoring  ●

DVD-ROM drive for installation from DVD (not required for installation from ●

download) 

 
Quark Publishing Platform NextGen Adapter for Microsoft Office require the 
following minimum software configuration: 

Windows 7® 64-bit (Enterprise, Professional or Ultimate)  ●

Windows 8® 64-bit  ●

Windows 8.1® 64-bit  ●

Windows 10® 64-bit ●

 
Quark Publishing Platform NextGen Adapter for Microsoft Office require one of 
the following versions of Microsoft® Office: 

Microsoft Office 2013 64 bit, Professional Edition (Build 4849.1000 or later) ●

Microsoft Office 2016 64 bit, Professional Edition (Semi-Annual Channel: ●

Version 2008. Released on September 8, 2020 or later) 

Microsoft Office 365 (2013 and 2016) 64-bit (Semi-Annual Channel: Version ●

2008. Released on September 8, 2020 or later)In addition, the following 
components are required for installation: 

Microsoft .NET Framework 4.7 or later. It is available for download at ●

Microsoft’s Download Center: https://www.microsoft.com/en-
us/download/details.aspx?id=55167  
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Once the required installation of Microsoft Office is complete, you may install 
Quark Publishing Platform NextGen Adapter for Microsoft Office.
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Install Quark Publishing Platform NextGen 
Adapter for Microsoft Office 

Installing the Quark Publishing Platform NextGen Adapter for Microsoft Office is 
a straightforward process. The installation wizard will guide you through each 
step of the process. These adapters can either be installed using a standard 
installer that installs all the selected adapters in one go. 

Before you begin to install the Quark Publishing Platform NextGen Adapter for 
Microsoft Office, be certain that all required software including Microsoft Office 
have already been installed. Also, run Office Updates at Microsoft.com to ensure 
the latest version is installed. Close all running instances of Microsoft Office. 

 

Standard Installation 
 To install Quark Publishing Platform NextGen Adapter for Microsoft Office using 
the Windows installer: 

From the installation media, double-click the setup.exe file and follow the ●

instructions on the screen. Quark Publishing Platform NextGen Adapter for 
Microsoft Office have been successfully installed.  

If an earlier version of Quark Publishing Platform NextGen Adapter for 

Microsoft Office has been installed, use Control Panel to uninstall all 
previous versions and patches. 

Updates for each of the adapters need to be installed manually. 
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System Setup and Preferences 

The System Setup and Preferences section provides details on connecting to 
the repository and specifying user preferences. 

Some preferences are not modifiable when a server connection is currently 

established. In that case, close all the open documents and then try again. 
 

Log On to a Repository 
You must be logged on to a repository to access features such as Save to Server 
(check-in) or open for editing (check-out).  

If you do not have your login information, contact your system administrator.  

To set up your login information:  

Select File > Open > Quark > Preferences.  1
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In the Preferences dialog box, select the tab Connection Settings. 2

 

In Connection Settings:  3

Enter the URL of the server/repository you want to connect to. 1

Select the sign “+” to add the URL to the list of saved repositories.  2

Select the URL of the repository you just added. 3

Select Load. 4
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Select Log On to open the Log On dialog box of the repository. 5

 

 
In the Log On dialog box, enter your login information and select Login. The 4
Log On dialog box disappears once you are logged in.  
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Select OK in the Preferences dialog box. 5

When a document is already open, Quark Publishing Platform NextGen 

Adapter for Microsoft Office does not allow you to change preferences. You 
first have to close all the open documents and then apply any preference 
changes, such as changing a repository. 

 
Preferences 
You can use the Preferences tab of the File menu (File > Open > Quark > 
Preferences) to set your Quark Publishing Platform NextGen Adapter for 
Microsoft Office preferences.  

All other Quark Publishing Platform NextGen preferences are stored on the 
Quark Publishing Platform NextGen server.  

Set Preferences 
The Preference dialog box allows you to set various settings related to 
documents and repository. Some of the key settings are as follows:   

Set the Location of Published Documents  

You can specify the location of published documents on your local machine.  

To specify a location: 

Select File > Open > Quark > Preferences. 1

Select the tab General. 2

Select Browse to navigate to the folder where you want to save published 3
documents. 

Select OK.  4
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Deletion Options 

By default, Quark Publishing Platform NextGen Adapter for Microsoft Office 
deletes the file on your local machine when your save a document to the 
repository. The Deletion Options drop-down menu allows you to specify how 
you want Quark Publishing Platform NextGen Adapter for Microsoft Office to 
function when you save a document to the repository.  

To specify your preferences: 

In the Preferences dialog box, select the tab General.  1

Expand the Deletion Options drop-down menu.  2

Select from one of the following options:  3

Delete Without Warning ●

Never Allow Deletion ●

Ask Before Deleting   ●
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Revision Comments 

The Revision Comments drop-down menu allows you to specify when you want 
to see the revision comments. The available options are:  

Always ●

Never ●

New Assignments Only   ●
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Update Version on Save 

The Update Version on Save checkbox allows you to specify whether you want 
Quark Publishing Platform NextGen Adapter for Microsoft Office to create a new 
version of the document when you save a revision through Microsoft Word’s 
Save option. 

 

Reset to Default  

If you want to change the preferences that you have made to the default 
preferences: 

Select the tab Advanced in the Preferences dialog box. 1
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Select Reset to Default and then select OK.  2

 

You must close all server documents and log off before you reset 

preferences. 

 
Clear Cache 

If you want to clear the cache when you are done working with Quark Publishing 
Platform NextGen Adapter for Microsoft Office: 

Select the tab Advanced in the Preferences dialog box. 1

Select Clear Cache.  2
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Quark Publishing Platform NextGen Adapter for Microsoft Office prompts a 3
dialog box for you to confirm the action. 

 

Select OK. 4
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Work with a Platform Repository 

Create a New Document from a Template 
Quark Publishing Platform NextGen Adapter for Microsoft Office allows you to 
use documents that are already available in the repository as templates to 
create new documents.  

To create a new document from a template: 

Select File > New Document from Server. 1

In the Available Templates menu, select New Document from Server 2
Template.
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In the Select Template dialog, you can find the template that you want to use 3
in the following ways: 

 

Select one of the following paginated browsing tabs and navigate to the 1
template: 

Favorites: Lists the most frequently used folders and files.  ●

My Assignments: Lists the documents assigned to you (logged-in ●

user). 

Searches: Lists the Saved Searches on Server that are accessible to ●

you. 

Continue Editing: List the documents that you are currently working ●

on.  

Browse: Displays the document repository that is accessible to you. ●

 
Search for the template in the Search tool. 2
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Select the template, and then select OK. 4

 

Quark Publishing Platform NextGen Adapter for Microsoft Office creates a 5
new document based on the template you selected. 
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Create a New Document from a Document 
Quark Publishing Platform NextGen Adapter for Microsoft Office allows you to 
use documents that are already available in the repository as templates to 
create new documents.  

To create a new document from a template: 

Select File > New Document from Server. 1

In the Available Templates menu, select New Document from Existing 2
Document. 

 

In the Select Document dialog, you can find the document that you want to 3
use in the following ways: 
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Select one of the following paginated browsing tabs and navigate to the 1
document: 

Favorites: Lists the most frequently used folders and files.  ●

My Assignments: Lists the documents assigned to you (logged-in ●

user). 

Searches: Lists the Saved Searches on Server that are accessible to ●

you. 

Continue Editing: List the documents that you are currently working ●

on.  

Browse: Displays the document repository that is accessible to you. ●

 
Search for the document in the Search tool. 2

 
Select the document, and then select OK. 4
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Quark Publishing Platform NextGen Adapter for Microsoft Office creates a 5
new document based on the document you selected. 

 

 
Open a Document from the Repository to Edit and View 
Quark Publishing Platform NextGen Adapter for Microsoft Office allows you to 
open documents that are already saved in the repository.  

To open a document from the repository: 

Select File > Open > Quark > Browse.  1
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In the Open from Server dialog box, use one of the paginated tabs or the 2
Search tool to find to document that you want to edit or view.  

 

Select the document and: 3

select Open if you want to edit the document. 1

select Read Only if you only want to view the document. 2

 
Quark Publishing Platform NextGen Adapter for Microsoft Office opens the 4
document.  
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When you try to edit a document that you have opened for viewing only, 

Quark Publishing Platform NextGen Adapter for Microsoft Office requires you 
to create a new copy of the document to save the changes. The original 
document remains unchanged.   

The view in your repository software and the Open from Server dialog show 

the file with the checked out icon . The Checked Out by field is set to your 
User Name. When you are finished authoring, save the document to the 
repository.  

 

Save Document Revisions 
You can save and check in a document from the Office application it is open in. 
Components within the document will be available for referencing by other 
documents. For new documents, specify the desired repository folder and 
filename. 

You can choose to check in and close the document or keep it checked out and 
open for further editing. 
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To save a revision of a document: 

Perform one of the following: 1

To keep the document open: Choose File > Save to Server. ●

To close documents: Choose File >Done Editing. ●

 

 
The Save dialog box displays. The dialog box displays repository-related 
information about the document you are saving. 

You are not allowed to change the collection where the document is located 

when you are saving a revision. This can only be done when you are doing 
Done Editing (Save/Close a document). 
In the Save dialog box, select a location in the repository where you want to 2
save your document.   
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Select a workflow from the Workflow drop-down menu. Workflows define the 3
lifecycle stages of a document. For example, the workflow of a document 
can have the stages - Author, Review, and Publish. 
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Select a stage from the Status drop-down menu within the selected 
workflow. By default, Quark Publishing Platform NextGen Adapter for 
Microsoft Office selects the stage that is listed first in the list or the stage 
that the document is already in if the document is a revision of an already 
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available document.     
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Choose the people or group you want to assign (for example, for review) the 4
authored document, if required, and then select Assign. 

 

If your workflow uses automatic status-based assignment, the Assign To 

menu automatically selects people/group when you select an option from 
the Status drop-down menu. 
Enter a revision comment, if required. 5

Quark Publishing Platform NextGen Adapter for Microsoft Office displays 

revision comments when you open a document to view or to edit. 
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Choose a version type to check the file in as a Major Version or Minor 6
Version. 

 

Select Save.  7

In the Save dialog box, there are several fields that represents the metadata of 
the current document such as created by, last modified, checked-out by, and 
so on. 

Quark Publishing Platform NextGen Adapter for Microsoft Office retains 

edited attribute values when you change the collection (location in the 
repository) or the workflow of an asset unless these values are not 
applicable in the selected collection. 

When a document contains validation rules, Quark Publishing Platform 

NextGen Adapter for Microsoft Office evaluates these rules when you save 
the document and notifies of if any rules are being violated. For example, 
certain fields are empty that must have a value. 

 
Discard Changes 
You can use the Discard Check Out feature to cancel the checkout of a 
document. All authoring changes will be discarded. 

The document must already be open in the application. 

To discard check out: 

Choose File > Close 1

The system prompts, Do you want to revert changes?. Click Yes. 2
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Changes made to the document since it was checked out are discarded and the 
document is closed. 

The view in your repository software and the Open from Server dialog show 

the file without the checked out icon. The Checked Out By field is cleared. 
The document status changes from checked out to checked in. 

 
Close Server Documents 
Documents checked out from the Quark Publishing Platform NextGen server 
need to be saved to the server or saved and closed to preserve any changes 
made to them locally. Closing the document via a keyboard shortcut, through 
the File menu or by clicking on the Close icon on the top right-hand corner of 
the window displays a dialog with the following options:  

  

 

Done Editing: Updates the Quark Publishing Platform NextGen server with 1
your most current changes, checks in and then closes the project or 
template. 

Discard Changes: Discards the checkout, closes the project or template and 2
makes it available for others to check out. An alert displays, allowing you to 
save or discard any changes made since your checkout. If you saved a 
revision on Quark Publishing Platform Server, it becomes the current version 
when you cancel a checkout. 

Close: Closes the document. If the document has not been saved, an alert 3
displays, allowing you to save the open document locally. If you choose 
Don’t Save, the document is closed with the last saved change. Choosing 
Cancel dismisses the alert. 
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Quark Publishing Platform NextGen User 
Interface 

Users can access their Quark Publishing Platform NextGen workflow through 
the Quark Publishing Platform NextGen Adapter for Microsoft Office. This 
chapter provides details of the Quark Publishing Platform NextGen user 
interface available in PowerPoint, Word, and Excel on Microsoft Windows®. 

 

Quark Publishing Platform NextGen Adapter for 
Microsoft Office - Excel 
Quark Publishing Platform NextGen Adapter for Microsoft Office - Excel allows 
users to create new documents using a document or a template available on the 
server and check in and check out files from the Platform repository. 

Supported File Types 

Quark Publishing Platform NextGen Adapter for Microsoft Office - Excel 
currently supports the following formats: 

.xslx (Excel Workbook) ●

.xltx (Excel Template) ●

.xlsb (Excel Binary Workbook) ●

.xlsm (Excel Macro-Enabled Workbook) ●

 

Componentization in Microsoft Excel 
Componentization in Microsoft Excel is aimed at editorial flows that may require 
the source documents to be independent of exported components, yet retaining 
the capability to update them. 

Data in Microsoft Excel workbooks can be exported to multiple formats as 
components. These components can be referenced directly in Quark XML 
Author, Quark Author Web Edition and Microsoft PowerPoint. 

Components can be exported from local Excel workbooks without checking in 
the source documents to the Platform server, preserving the formatting and 
content of the source document. 
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The formatting and content of ranges or charts exported as Microsoft Excel can 
be altered, although a link to the original document is maintained. If the source 
requires changes to its structure or content, all linked components can be 
updated. Any components that do not require to be linked to the source 
document can be delinked. 

Export Ranges from Microsoft Excel 

Selected ranges in Microsoft Excel can be exported as various content types. To 
export a selected range: 

Select a range of cells. 1

Invoke the contextual menu and choose an option from Smart Content > 2

Export As >:  

Excel Table: Ranges are exported as a new Excel workbook with all ●

formatting information and values. Formulas and references are not 
exported. 

JPEG: Exports the selected range as an image (jpg). ●

PDF: Exports the selected range as an image (pdf). ●

PNG: Exports the selected range as an image (png). ●

 
Exporting a range containing a formula or a link will only export its value. 
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Exporting a range again will change the contextual menu entry to Smart 

Content > Export Again As 

 

Local edits to the exported Excel table will be overwritten when the 

components are exported again. 

If the Selected range is not named, a dialog to set a name for the exported 

range will be displayed. 
Enter a name for the range or use the suggested name. Set the scope of the 3
range. The scope of a range can be limited to the current sheet or made 
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available throughout the workbook. Click OK. The Save dialog displays. 

 

The Name drop-down list only displays ranges with scope set to the current 

sheet or throughout the workbook 
Navigate to the required repository folder and click Save. 4

 

If a component with the same name exists in the destination, an alert with an 

option to change the name of the asset 
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displays.

 
The selected range is saved to the server with the specified name.  

Exported components contain an attribute with information about the local 

path of the file from which the component was exported. If changes are 
required in the original file, the local file can be edited by choosing Edit 
Original from the contextual menu in Quark XML Author. 

 

Export Charts from Microsoft Excel 

Charts in Microsoft Excel can be exported as various content types.  

To export a chart: 

Select the chart. 1

Invoke the contextual menu and choose Smart Content > Export As> and 2
then select one of the following:   

Excel Chart: Charts are exported as a new Excel workbook with all ●

formatting information and values. 

JPG: Exports the selected chart as an image (.jpg). ●

PDF: Exports the selected chart as an image (.pdf). ●

PNG: Exports the selected chart as an image (.png). ●
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Exporting a chart again will change the contextual menu entry to Smart 

Content > Export Again As. 

 

Enter a name for the chart or use the suggested name.  3

If a chart with the same name exists in the Excel document, an alert with an 
option to change the name of the chart displays.   

The save process needs to be re-initiated once the name of the chart is 
changed. The Save dialog displays. 

Navigate to the required repository folder and click Save.   4

If a component with the same name exists in the server, an alert with an 

option to change the name of the component displays.   

The component is saved to the server with the specified name. 

 

Push Updates 

The Push Updates button in the ribbon updates changes made to all linked 
components exported from Microsoft Excel to the Quark Publishing Platform 
NextGen server. These updates occur silently. No input is required from the user 
after clicking the Push Updates button. 

 

Once the update process is complete, the Smart Content pane is automatically 
refreshed and displays the updated versions of the components. 

 

Smart Content Pane in Microsoft Excel 
The Smart Content Pane is available for all supported Microsoft Office 
applications, however, the contextual menu options offered by the Smart 
Content Pane may differ across these applications. The Smart Content pane in 
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Microsoft Excel lists the components that have been exported from the currently 
open document. To show/hide the Smart Content pane, click the Smart Content 
Pane button in the Home ribbon.   

 

The following operations can be performed on the components listed in the 
Smart Content Pane: 

Go To: Selects the exported range on the worksheet. ●

 
Update Link: Saves a revision of the component to the Platform server that ●

includes any changes made to the component. 

Edit Link: Opens the selected component for editing in Microsoft Excel. The ●

component will be updated once checked in to the server. 

This option is only available for Microsoft Excel components. 

Break Link: Breaks the link between the exported component and the ●

document the range was exported from. 

Link to Selected Range: Choosing this option displays a dialog.  ●

 

Choosing Link from the dialog links the exported component to currently 
selected range other than the originally exported range. If no name has been 
specified for the range, a name must be set for the new range. The components 
of the range need to be updated by invoking the contextual menu from the 
worksheet or from the Smart Content pane. Selecting Link & Update links the 
exported component to the currently selected range and updates the selected 
component in one step. 
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View Revisions: Displays a list of revisions a component has undergone. ●

Where Used: Displays a list of documents where this component has been ●

referred. 

Properties: Displays the attributes of the components from the server. ●

Preview: Displays a preview of the selected component. Multiple preview ●

channels can be configured.  

 

 
Quark Publishing Platform NextGen Adapter for 
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Microsoft Office - PowerPoint 
Quark Publishing Platform NextGen Adapter for Microsoft Office - PowerPoint 
allows users to manage, reuse and create new presentations using slides, Excel 
tables, Excel charts, audio, video, and images available on the server and check 
in and check out files from the Platform repository. Users can easily update slide 
decks and reference components as needed, all while maintaining familiar 
PowerPoint features for editing and design.  

Supported File Types 

Quark Publishing Platform NextGen Adapter for Microsoft Office - PowerPoint 
currently supports the following formats: 

.pptx (PowerPoint Presentations) ●

.potx (PowerPoint Templates) ●

.pptm (Macro enabled PowerPoint Presentations) ●

.potm (Macro enabled PowerPoint Templates) ●

 
Slides from checked-in documents will be available for referencing in Microsoft 
PowerPoint, Quark XML Author or Quark Author. 

PowerPoint Slide assembly 
PowerPoint users can easily assemble slides by reusing slides or complete 
PowerPoint decks from the Server. Users can also easily update slide decks and 
reference components as needed from the Quark Publishing Platform NextGen 
server, all while maintaining familiar PowerPoint features for editing and design. 

Insert Slides 

Slides checked in to the Quark Publishing Platform NextGen server can be 
inserted into a PowerPoint presentation. To insert slides from the Platform 
server: 

Choose Reuse Slides from Server from the Platform ribbon or from the 1
contextual menu. The Reuse Slides from Server dialog displays. 
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Browse to the required slide and click OK. 2

 

Previous versions of the selected asset can also be chosen using the 

Versions button. 
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On clicking the version button, all the versions of the selected document will 
be listed and you can select the required version. 

 

Once the document is selected, the path to slide is updated in Insert slides 
from and the available slides are populated in the Reuse Slides from Server 
pane.     

Select the slides that you wish to insert and choose Insert Slide(s). Choose 3
Insert Deck to insert the entire slide deck.                                                                                   

 

The File Save dialog displays if the PowerPoint presentation has not been 

saved. Click Save to save the file to your computer. 

If the Keep source formatting checkbox is deselected, the existing formatting 

of the slides will be overridden and the formatting of the current PowerPoint 
presentation will be applied to them. 

If the Link to server checkbox is deselected, this document cannot be 

updated to the latest version available on the server. 
The slides are added to the PowerPoint document. 
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Component References 
In addition to existing slides and PowerPoint decks, server components such as 
Excel tables, Excel charts, audio, video and images can also be easily added to 
slides.  

Picture from Server 

Pictures checked into the platform server can easily be added to enrich 
PowerPoint slides. To insert a picture into a PowerPoint Slide:  

Click the Picture from Server button in the Platform 1
ribbon.

 

Browse to the desired picture in the Insert dialog. 2

 

Previous versions of the selected asset can also be chosen using the Version 

button . 
Click OK. 3
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The inserted picture can be replaced with another picture from server by 

selecting Change Picture from the contextual menu. 
The selected picture is inserted into the PowerPoint slide. 

 

Chart from server 

Microsoft Excel Charts can be added to slides as an editable object or as a 
shape. No content modification or range selection is possible when charts are 
added as a shape.  

The following types of charts can be added to slides: 

Microsoft Excel Chart as Shape - The chart is added to the slide as a graphic. ●

Content modification is not permitted. 

Microsoft Excel Chart - Content modification and range selection is ●

permitted. Displayed data in these charts can be modified. 

 

Inserting Microsoft Excel charts 
Microsoft Excel Charts can be added to slides as editable objects. The design, 
formatting and data values of the chart can be edited within Microsoft 
PowerPoint.  

To insert a Microsoft Excel Chart: 

Choose Chart from Server > Microsoft Excel Chart from the Platform ribbon. 1

 

Browse to the desired Chart in the Insert dialog.   2

Click OK. If the selected Chart is a Microsoft Excel document, the Insert Chart 3
dialog displays. 
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Choose the desired sheet and chart and click OK to insert the chart.  4

 
The selected Chart is inserted. These charts can be edited akin to native 

PowerPoint Charts.  
 

Customizing charts in a PowerPoint document 
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Clicking the  icon opens the Chart Elements flyout menu. Items from the 
menu can be selected or deselected.  

 

 

Clicking the icon opens the Style and Color flyout menu. The styling and 
color scheme of the chart can be altered from this menu.  
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Clicking the icon opens the Values and Names flyout menu.  

 

Inserting Microsoft Excel Chart as Shape 
Charts checked in the Platform server can easily be added to PowerPoint slides 
as a shape. To add a Microsoft Excel Chart as a shape: 

Choose Chart from Server > Microsoft Excel Chart as Shape from the 1
Platform 
ribbon.
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Browse to the desired Chart in the Insert dialog. 2

 

Previous versions of the selected asset can also be chosen using the Version 

button . 
Click OK. If the selected table is a Microsoft Excel document, the Insert Chart 3
dialog displays. 

 

 Adapter for Microsoft Office User Guide | 46



Select the desired sheet and Chart and click OK to insert the chart. 4

The selected Chart is inserted. 

Charts inserted as a shape cannot be edited. 

The inserted chart can be replaced by another chart from server by selecting 

Change Link from the contextual menu. 

 

Paste from Server 

Tables and charts can be copied from Microsoft Excel using the Quark 
Publishing Platform NextGen Adapter for Microsoft Office - Excel. The Quark 
Publishing Platform NextGen server facilitates pasting the copied items in 
PowerPoint, Quark Author and Quark XML 
Author.

 

 

The copied items can be pasted using the Paste from Server button. Copied 
Excel tables will be pasted as native PowerPoint shapes and copied charts as 
native PowerPoint charts (as long as the logged on user is the same). 

A link to the server is not maintained with components pasted from the 

server clipboard. 

Video from Server 

Video files checked into the platform server can easily be added to enrich 
PowerPoint slides. To insert a video into a PowerPoint Slide:  

Click the Video from Server button in the Platform ribbon. 1
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Browse to the desired video in the Insert dialog. 2

 

Previous versions of the selected asset can also be chosen using the Version 

button. 
Click OK. The selected video is inserted into the PowerPoint slide.  3

 Only server images can be used as poster images for Server videos. 

You can add a poster image for the inserted video clip. To insert a poster 

image, choose Change Poster Image from the contextual menu or click 
Format > Poster Frame > Image from File. 

The inserted video can be replaced with another video from server by 

selecting Change Link from the contextual menu. 

 

Audio from server 

Audio files checked into the platform server can easily be added to enrich 
PowerPoint slides. To insert an audio clip:  

Click the Audio from server button in the Platform ribbon. 1
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Browse to the desired audio clip in the Insert dialog. 2

 

Previous versions of the selected asset can also be chosen using the Version 

button . 
Click OK. The selected audio is inserted into the PowerPoint slide. 3

You can add a cover image for the inserted audio clip. To insert a cover 

image, choose Change Picture from the contextual menu or select Format 
>Change Picture. 

Only server images can be used as cover images for server audio clips. 

The inserted audio clip can be replaced with another audio clip from server 

by selecting Change Link from the contextual menu. 

 

The Smart Content Pane in Microsoft PowerPoint 
The Smart Content pane is available in Microsoft Excel and PowerPoint, 
however, the contextual menu options offered by the Smart Content pane may 
differ across these applications.  

In Microsoft PowerPoint, the Smart Content Pane lists the components referred 
from the Quark Publishing Platform NextGen server. To show/hide the Smart 
Content pane, click the Smart Content Pane button in the Home or the Platform 
ribbon.  
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 Changes and updates to referred components are indicated with the  
indicator in the Smart Content pane in Microsoft PowerPoint.  

 

Updates to any referred components are also indicated in the Smart Content 
pane icon.   

  

Invoking the contextual menu here provides the option to update the asset to 
the latest version available on the server. The metadata of the latest version will 
always be shown in the Smart Content Pane. If the inserted asset has been 

checked out from the server, the checked-out icon will be displayed  in the 
right hand corner. The Smart Content pane in Microsoft PowerPoint allows the 
following operations to be performed on the listed components via the 
contextual menu: 

Go to: Moves the focus to the selected reference on the canvas. ●

 
Update Link: The element reference is refreshed. Local changes will be ●

replaced with the latest content on the server. 

Break Link: The link to the server asset is removed. Any changes made to the ●

asset on the server will not be reflected in the client. 

Edit Original: Opens the original Excel document from which the referred ●

table, picture or chart has been exported for editing. 

Edit Link: The referred table, chart or PowerPoint slide is checked out to be ●

edited. 

Open Link: Opens a read-only copy of the asset the element is referred from. ●
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Convert to Local Link: Converts a server reference to a local reference by ●

downloading the server asset locally. 

View Revisions: Displays a list of revisions a component has undergone. ●

Where Used: Displays a list of documents where this component has been ●

referred. 

Properties: Displays the attributes of the components from the server. ●

Preview: Displays a preview of the selected component. Multiple preview ●

channels can be configured. 
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Multi-channel Publishing 
The Quark Publishing Platform NextGen Adapter for Microsoft Office - 
PowerPoint facilitates the publishing of a PowerPoint slide deck to various 
formats.   

Slides can be published as PDF, Responsive HTML 5 or PPSX. 

Publish as PDF ●

Publishing slides as PDF creates a PDF of the entire slide deck. All server 
references are resolved prior to publishing the slides. 

Publish as Responsive HTML5 ●

Publishing slides as Responsive HTML5 creates an HTML rendition of the entire 
slide deck. All server references are resolved prior to publishing the slides. 

Publish as PPSX ●

Publishing slides as PPSX creates a PowerPoint slideshow of the entire slide 
deck. All server references are resolved prior to publishing the slides. 

 
To export a presentation in one of the available formats:  

Open Smart Content pane. 1

Click on Preview icon.  2
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In the Preview tab, select the required output format.  3

Click on the Download icon.  4
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Quark Publishing Platform NextGen Adapter for 
Microsoft Office - Word 
Quark Publishing Platform NextGen Adapter for Microsoft Office - Word allows 
users to create new documents using a document or a template available on the 
server and check in and check out files from the Platform repository. 

Supported File Types 

 Quark Publishing Platform NextGen Adapter for Microsoft Office - Word 
currently supports the following formats: 

.docx (Word Document) ●

.dotx (Word Template) ●

 Component referencing is currently not supported for Microsoft Word 

documents. 
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Contacting Quark 

The support portal allows you to log support tickets, track tickets, receive status 
notifications, chat with a technical support representative, search the 
Knowledge Base, and access product documentation.  

With direct access to documentation across all Quark software - from 
QuarkXPress and App Studio to Quark Enterprise Solutions - you can find 
answers to your questions at your convenience. Our support team is also 
available to help, either through our support portal, or via phone for our 
maintenance contract customers.  

If you are a Quark customer and have a current maintenance or support contract 
your account has already been created for you using your registered email 
address. If you do not have a support contract you can purchase a single 
support incident to get your problem resolved. If you have purchased or 
registered a supported product, you are eligible for free support for the first 90 
days. 

For more information, visit Quark support website.  

English: www.quark.com/support ●

French: www.quark.com/fr/support ●

German: www.quark.com/de/support ●

 
  

Outside the Americas 
 For countries outside the Americas, please visit the following sites to access 
your support account: 

Support Website 

 France - www.quark.com/fr/support ●

Germany - www.quark.com/de/support ●
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Quark is the basis for content creation, automation and intelligence. Since 1981, the company has been a pioneer in 
graphic design, digital publishing and content automation. Today, customers rely on Quark for closed-loop content 
lifecycle management to deliver optimized content to meet their desired use cases – from digital magazines that 
entertain to documents that demonstrate regulatory compliance. Headquartered in Grand Rapids, Mich., we serve more 
than 100 enterprise customers and 50,000 users worldwide. Quark. Brilliant content that works. For more information, 
visit www.quark.com.  

© 2022 Quark Software, Inc. All rights reserved. All trademarks, trade names, service marks and logos referenced herein belong to their respective owners.  
This content is informational and does not imply any guarantee or warranty.   
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